当前位置: 安卓之星 -> 安卓开发 -> This support library should not use a different version (23) than the compileSdkVersion (25)

This support library should not use a different version (23) than the compileSdkVersion (25)

作者:网络 发表于: 2017-04-28 点击: 1,176 次

compile ‘com.android.support:appcompat-v7:23.4.0’

这里,我在android studio里使用了最新的编译版本android7.0,api为25:

compileSdkVersion 25

buildToolsVersion ‘25.0.3’

显然support v7里用的是23,而gradle里显示编译错误,要26,而26又没法在25下面编译。

解决方法:

改为 compile ‘com.android.support:appcompat-v7’ 不用加版本号,编译通过,很简单吧!

相关文章

相关文章

赶快留言冒泡

  • 评论 (0)
  • 引用通告 (0)
目前还没有任何评论.
目前还没有任何Trackbacks和Pingbacks.
吐个泡浮上去.